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Playing With Shaped Wire & Framed Wire Art – Part 2

Introduction

This is Part 2 of a three part set of tutorials on creating shaped wire and wire framed artworks 
and specifically covers wire grid creating simple 'paths' stroked with brushes. All assumptions 
and additional introductory commentary can be found in Part 1.

We will create three wire grids adding a little more complexity at each attempt.

Part 2 - Section 1 – using paths & a rope brush to create a circular wire grid

Our objective here is to create some simple paths to form a large grid pattern, then stroke those
paths with a rope brush and then turn it into a metallic wire pattern; this should only take about 
10 minutes. OK lets start; but remember to save your xcf file regularly.

1. Create a new canvas of 800 x800 pixels with a black background.
2. Now set up guides as follows:

1. Horizontally at 150 pixels, 400 pixels and 650 pixels
2. Vertically at 150 pixels, 400 pixels and 650 pixels

3. Select the Ellipse Select Tool from the Tool Box and apply the settings shown below 

4. Place your cursor exactly over the centre crossing guides and drag the ellipse selection 
out until it reaches the guides at 150 and 650 pixels. Then right click and Select>To Path 
and then Select None.

5. Now select the Paths Tool from the Tool Box and position your cursor at the top of the 
centre vertical guide and left click. Then move your cursor to the bottom of the guide and 
click again.

6. Now open the Paths Dialogue window by clicking on the Paths Tab. Make the vertical 
path active, right click and Duplicate Path.

7. With the duplicated path active, select the Rotate Tool from the Tool Box, ensure that in 
Tool Options the paths Icon is selected too, then click on the canvas to open the Rotate 
Window and set 90 as the Angle amount, then click the Rotate button to give you crossed
paths.
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8. The ellipse path should not be visible right now, if it is make it invisible, then right click in 
the Paths Dialogue and select Merge Visible Paths to give you crossed paths. Make both
paths visible and you should have a canvas looking like this -

9. Return to the Layers Dialogue and create a new transparent layer. Select the Brush tool 
from the Tool Box and in Tool Options – Brush choose the Rope Brush 04 Arvin61r58 
which was included in this tutorial package and apply the settings as shown below; note 
there is no need to change the brushes Spacing setting -

10.Now with the merged paths active in the Paths Dialogue, select Edit>Stroke Path to 
display the window and set the parameters as shown below, so that the Brush Dynamic 
Settings are in force then click on the Stroke button -
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11. After step 10 you should now see a canvas with the stroked crossing paths looking like 
this -

12.Make the ellipse path active and in the Layers Dialogue create a new transparent layer. 
Again select Edit>Stroke Path and hit the Stroke button.

13.Your canvas should now look this -

14.Now make the stroked crossed paths layer active, right click and Select From Path, 
which will give you a circular selection covering the crossed brush strokes in centre 
canvas. Press the Delete button on your keyboard to clear that centre cross but leave the
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strokes on the canvas edges.
15.Make the black background layer invisible then right click and select New from Visible to 

obtain a combined stroked path layer with a transparent background.
16.Select Filters>Distorts>Emboss to display that window, leave the default settings as is 

then click OK to give the stroked layer a textured metallic look.  
17.Now, just to give the wire an even better metallic look, let's select GMIC>Contours>Local 

orientation>CMYK(key) and click Apply to create a new layer. Set the blend mode to 
Grain Merge, then right click to show the layers menu and select New From Visible. Your 
canvas should now look like the example below -

18.We have completed the basic wire framework so now, with that new visible layer active, 
you can select GMIC>Arrays & tiles Array(regular), leave the settings at default then click
Apply. Make all lower layers invisible but switch the black background layer to visible. You
should have a canvas looking like this - 

19.You may wish to stop now and save this as your new wire pattern. My preference was to 
repeat the GMIC function to deliver this version -
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And once again that is it; congratulations you have now completed your first path based wire 
tutorial.
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Part 2 - Section 2 – using paths/brush to create a more complex wire grid

Our objective here is to create multiple paths to form a large grid pattern, then stroke those 
paths with a rope brush. We then add some metallic character and then turn it into a wire 
pattern; this should only take about 15 minutes. OK lets start; but remember to save your xcf file
regularly.

1. Create a new canvas of 800 x800 pixels with a black background.
2. Now ensure that in your View Menu that Snap to Guides is set on (ticked). Then create 

new guides as follows:
1. Horizontally at 100 pixels, 400 pixels and 700 pixels
2. Vertically at 100 pixels, 400 pixels and 700 pixels

3. Select the Rectangle Select Tool from the Tool Box and use the settings in the Tool 
Options as shown below.

4. Place your cursor exactly over the two crossing guides at 100 pixels horizontal and 
vertical, hold the left mouse button down, then drag the square selection diagonally down
to the crossing guides at 700 pixels and release the button. Then right click and 
Select>To Path and then Select None.

5. Now open the Paths Dialogue window by clicking on the Paths Tab. Make the square 
path named Selection active, then right click and Duplicate Path.

6. With the duplicated path active, select the Scale from the Tool Box, ensure that in Tool 
Options the paths Icon is selected too, then click on the canvas to open the Scale 
Window. Use the settings as shown in the example below, then click the Scale button to 
give effect to the 50% change in size

7. You should then see your duplicated and scaled path towards the top left of the canvas 
as shown below, which is not actually where we want it.
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8. So select the Move Tool from the Tool Box, ensure that the Path icon is set active in Tool 
Options and then click on the path and drag it to position its bottom right corner on the 
two crossing guides at 700 pixels. Because we are using snap to guides the path should 
snap into the correct position.

9. Now repeat the actions in steps 7 and 8, but use 75% for the scaling factor not 50%. So 
now we will have three square paths all similarly positioned at the bottom right corner.

10.  We will now add some side handle to complete a tileable pattern. So now select the 
Ellipse Select Tool from the Tool box and ensure that you have the settings shown in the 
example below -

11. Now place your cursor at the intersection of the guides at 400 horizontal and 700 vertical 
hold down the left button and draw out the circle to the canvas edge, then release the 
button to complete the selection.

12.Select the Rectangle Select Tool again, but ensure that you clear all our previous settings
from and then click on the Subtract from the current selection icon in the Tool Options.

13.  Place your cursor on the 700 pixel vertical guide well above the active ellipse selection, 
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hold down the left mouse button, draw out a rectangular selection diagonally down left 
until past the left and bottom edges of the ellipse selection and release the mouse button.
This will now leave you with a semicircular selection so right click and choose Select>To 
Path and then Select>None.

14.Open the Paths Dialogue and make the new semicircular path active and visible, then 
right click and choose Duplicate Path from the menu.

15.With this new duplicated path active, select the Flip Tool, click on the Horizontal radio 
button in the Tool Options, then click on the canvas to flip this path to the left side.

16.Again right click and duplicate this path. With the newly duplicated path active, select the 
Rotate Tool from the Tool Box. In the rotate window set the angle to 90º and click Rotate. 
The path should now appear at the top of the canvas.

17.Once more duplicate this path and repeat the flipping action in step 15 but this time with 
the Vertical radio button set; this newly duplicated path should now appear at the bottom 
of your canvas. You can now select Image>Guides>Remove All Guides then with all 
paths set as visible your canvas should look like this -

18.Now in the Paths Dialogue right click and select Merge Visible Paths.
19.From the Tool Box select the Paintbrush Tool and choose the Rope Brush 01 Arvin61r58 

that was included with this tutorial package. Set the Size to 30 pixels and set Track 
Direction on in the Dynamics drop down as shown below -

20.Select Edit>Stroke Path to open that window and ensure the settings are as shown 
below and then click the Stroke button -
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21.Your canvas should now show an image with a two tone brown rope, just like the 
example that follows -

22.Click on the Select by Color Tool  and click anywhere on the lighter of the two brown 
colours to create a selection of that colour across the image.

23.Select Filters>Distorts>Emboss to show that window and change the settings to those 
shown below then click the OK button to process the filter - 
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24.You should have a silvery and brown image and we will now get a little more 
adventurous. So select Filters>GMIC>Contours>Local orientation and change the 
settings in the Channels drop down to CMYK [key]. Then click the Apply button and 
GMIC will provide you with a shiny metallic image like this -

25.Select GMIC>Arrays & tiles>Array [mirrored] then click Apply and a new wire grid will 
magically appear. At this stage you may want to keep this as your final wire pattern. If so 
go directly to step 27.

26.My preference was to repeat step 25 on the new array and produce an image looking like
this example -

27.Now with this new GMIC array layer active, select the Select by Color Tool and click on 
any transparent area on the layer, then Select>Invert to make the selection that of the 
wire. Select Script-Fu>Effects>Shine and using the settings shown below, click OK -
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28.Now just above the original black background layer, create a new transparent layer and 
fill it with colour ffd697. Duplicate this coloured layer and set its blend mode to Overlay 
and you should end up with your final image looking something like this, with shadows to 
give it depth - 

29.Of course you can now make the shadows and all background layers invisible, right click 
and Select>New from Visible, then run Filters>Enhance>Unsharp Mask to refine the new
image and save it as your new wire pattern.

And once again that is it; congratulations you have now completed your second path based wire
tutorial.
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Part 2 - Section 3 – using paths & a twisted wire brush to create a wire grid

The objective of this section is just to have some fun creating a 'twisted wire' grid pattern from a 
couple of brushes I made. Sometimes I find it pleasantly surprising when I make a mistake in 
GIMP, but love the result. That is where this final image came from. Serendipity can be your 
friend. OK lets start; but remember to save your xcf file regularly.

1. Create a new canvas of 800 x800 pixels with a white background.
2. Now ensure that in your View Menu that Snap to Guides is set on (ticked). Then create 

new guides as follows:
1. Horizontally at 100 pixels, 400 pixels and 700 pixels
2. Vertically at 100 pixels, 400 pixels and 700 pixels

3. Select the Ellipse Select Tool from the Tool Box and using the settings in the Tool Options
as shown below, place your cursor on the centre 400 x400 pixel guideline intersection, 
hold down the left button and drag the ellipse selection down and right to the guideline 
intersection at 700 x700 pixels, then release the button.

4. Select Selection>To Path then Select>None.
5. Now from the Tool Box select the Paintbrush Tool and from the Brush drop down choose 

the omg_twisted_wire_small brush provided in this tutorial package. Leave all the 
settings at their native value except in the Dynamics drop down select Track Direction.

6. Now select Edit>Stroke Path and click on the Stroke button having set the parameter 
values as we used previously and as reiterated below -

7. After this operation your canvas should look just like this -
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8. Now duplicate this layer and change the duplicated layer's blend mode to Overlay.
9. Change the Aspect ratio setting for the brush to 10, then create a new transparent layer 

and once again  Edit>Stroke Path and click on the Stroke button. Now change the blend 
mode of this stroked layer to Hard Light and duplicate it.

10.What you see on your canvas now should be shiny and look something like this -

11. Now create a new transparent layer immediately above your white background layer and 
change the brush to omg_twisted_wire. Ensure all the Tool Options settings to match 
those shown below (dynamics off); these are the brushes native settings. 

12. It is a large brush but position your cursor directly over the guideline intersection at the 
centre of the canvas and click to draw the  image. 

13.Now change the Angle of the brush to 90 and once again position the cursor over the 
centre guideline intersection and click to create a cross shape.

14.Create another transparent layer above this, change the Angle of the brush to 45 and 
then position the brush with its top end just over the canvas border and its bottom end 
just past the canvas centre and click.

15.Duplicate this later and with the Flip Tool and the Horizontal radio button checked, flip this
new layer to the right. 
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16.Duplicate this new layer and flip it vertically this time.
17.Again duplicate the new layer and flip it horizontally this time.
18.Make the white background layer invisible and hopefully your canvas now looks like this -

19.You will note some slight protruding of the large brush cross both vertically and 
horizontally. So make your first stroked circle path layer active, use the Fuzzy Select Tool
to click on a transparent area outside of the circle to create a selection of that area.

20.Make the large twisted wire cross layer active and then press the delete key on your 
keyboard to clear those protrusions. Leave that selection active.

21.Now right click and select New from Visible to put all your brush layers together. Now for 
the fun part, select GMIC>Arrays & tiles>Array [mirrored] to produce a new patterned 
layer and once again select New from Visible. Your canvas should now resemble this 
example -

22.Repeat GMIC>Arrays & tiles>Array [mirrored] to produce yet another new patterned 
layer. Now your canvas will change to this -

8 August 2016 Created by 'Oldmangrumpy' for Gimp Chat Page 15



Playing With Shaped Wire & Framed Wire Art – Part 2

23.Now you have a choice of endings -
1. First option is to leave the selection in place and again right click and select New from

Visible to put the last two layers together and then repeat the GMIC>Arrays & 
tiles>Array [mirrored] step to produce another level of the patterned layer as shown -

 
2. Second option is to Select>None, again right click and select New from Visible to put 

the last two layers together and then repeat the GMIC>Arrays & tiles>Array [mirrored]
step to produce - 
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3. Or, of course you could do both and save each set as twisted wire patterns.
24. I finished mine off by adding a new background layer of colour ffd697 and then added 

another layer above it with a Shadows 1 radial gradient in Difference mode. My result 
was this -

And  that, for the final time in Part 2, is it; congratulations you have now completed your third 
path based wire tutorial and this one with twisted wire brushes.

Part Three of this set will detail various ways of making framed wire art using the wire patterns 
we have made so far in both their natural form and using GIMP and GMIC filters to (attractively) 
distort them.

Thank you for doing my tutorials, I trust that you had some fun.
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