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Preface and Caveats

Perspective in Art

I have never studied art 'per se', but several years ago when I started posting my images in 
Gimp Chat, I was persuaded by member Dinasset (a real artist!) to gain a better understanding 
of perspective. This tutorial and the technique involved is basically about creating bowls and 
pots that exhibit the desired perspective.

Perspective, and I quote from one of the links below, “is an art technique for creating an illusion 
of three dimensions (depth and space) on a two-dimensional (flat) surface. Perspective is what 
makes a painting seem to have form, distance, and look "real." The same rules of perspective 
apply to all subjects, whether it's a landscape, seascape, still life, interior scene, portrait, or 
figure painting”.

There are three key components in helping to obtain correct perspective when creating a digital 
image, drawing or painting; they are :

• Viewpoint - a normal viewpoint would be looking at a scene or object at eye level 
• Horizon line - the imaginary horizontal line in the distance that is eye level 
• Vanishing lines - lines drawn from the object to a point or points on the horizon.

I will make a couple of references to 'viewpoint' later in this document and for anybody who 
wishes to check out these components further, here are a couple of informative web links :

https://trembelingart.com/what-perspective-art-beginners/

https://www.thesprucecrafts.com/perspective-in-paintings-2578098 

The Map Object>Sphere Filter - Bowl/pot Form and Symmetry

In my early GIMP years (2014) I originally used this filter to create e-maps for use in GnuTux's 
Bevel Reflect Logo filter. Those e-maps were created by filling a square canvas with a colour, 
gradient or pattern and running the filter to produce a spherical outcome.

In this tutorial  I do not use a filled canvas to obtain my bowls and pots, but a transparent layer 
with a filled rectangular cross section, and  the key drivers of the final bowl/pot shape are the 
size of that cross section and its position on the canvas – more on that below.

The pots/bowls on the front cover of this document were created using a square canvas and 
this tutorial will use that example. The pot's basic symmetry derives from that square geometry, 
however, the technique will work just as well with a rectangular canvas that can be taller than it 
is wide or wider than it is tall.

The filter will adapt the form of the resulting bowls based on those canvas shapes/sizes and, 
depending on those canvas dimensions, will produce slimmer or squatter bowl shapes as 
shown in the example images below. 

It is, of course, possible to manipulate the shape of the bowl/pot outcome using the Scale Tool 
whilst still maintaining the perspective – more on that below in the processing steps.
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Slimmer shapes from tall rectangular canvas

Squatter shapes from wide rectangular canvas
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Patterns on the Bowls and Pots

The rectangular cross section being used for the target bowl will contain its base colours and 
any patterns that are to be included. Typically, a GIMP pattern or gradient could be used for the 
base colouring and/or a pattern brush could be stroked in either a straight line horizontally or in 
a curve or diagonal shape across the section. Also, a single pattern could be used, say in the 
middle of the cross section; experimentation is of the essence here.

However, note that for some vertically applied patterns (like those on the two bowls in the cover 
image) a degree of measurement and calculation is required to ensure that they wrap correctly 
to maintain proportionate spacing around the bowl/pot. For example, a pot patterned vertically 
like those in the cover image would require to have the pattern applied in the cross section as 
shown below, with each section edge containing 50% of the vertical pattern to cater for the 
wrap around effect of the filter.

Target vertical patterned bowl

Spacing of vertical patterns with 'gold noise pattern' at 50% on each edge
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Non Standard GIMP Filter

The second part of this tutorial uses an externally provided filter, a script called Chisel or 
Carve. If you do not already have this filter, it can be downloaded from the link below.

http://gimpchat.com/viewtopic.php?
f=9&t=19738&sid=30657e6ae52a0a38dc2841a820e2bf04 
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Introduction

As with all of my tutorials, this one is geared to new users of GIMP, is step based and hopefully 
includes sufficient details in those processing steps to aid newer users.

Conventions Used in This Tutorial

Instructions on accessing and using various GIMP functions and filters are expressed in the 
following format - Image>Guides>New Guide …

This means that the user with a mouse, firstly left clicks on Image from the main GIMP menu, 
which then shows a drop down list of Image options available.

From this list the user with a mouse then left clicks on Guides to show the Guides options 
available. From this list the user then left clicks on New Guide … to display the following form 
for completion:

A 'green arrow' as above will, be used to identify data fields for checking or data entry.

Layer names will be specified for ease of reference and to assist any repositioning or further 
action required on them. They will be expressed in the following format - 'layer name'. 

Objectives

The purpose of this tutorial is to demonstrate a flexible technique, using the standard GIMP filter
Map Object>Sphere, the parameters of which allow a GIMP user to create patterned bowls or 
pots with desired shape and perspective. Three individual pots/bowls of different shapes and 
will be created and some shape modification will be exemplified. 

A second part of the tutorial addresses the creation of a simple rim to the pot or bowl using the 
Select Tool, stroked paths and bevelling. 

The tutorial will also identify areas of flexibility inherent in this technique and encourage 
experimentation in those areas.
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Processing Steps

1. Set the Background colour to black, then choose File>New to open a form to create a 
new image; enter 1000 for Width and Height fields to obtain new canvas of 1000 x 1000 
pixels and then click OK.

2. We will now put some Guides onto the canvas to help us create the Cross Section 
layers that we use as input to the processing filter. We will be creating 3 pots/bowls and 
we will need 4 Guides to help us create the Selections we need to fill for that input. 
Move the cursor to the Horizontal Ruler at the top of the canvas, left click and drag a 
Horizontal Guide down to the 800 pixel mark on the left side canvas Vertical Ruler. 
Then repeat this process to place 3 more Horizontal Guides at 600, 500 and 200 pixels.
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3. You will now have a canvas with a single black Background layer in the Layer Dialogue
with the guides from step 2. Add a new transparent layer above the Background layer 
by right clicking on the Background layer and selecting New Layer from the pop up 
menu to display the New Layer dialogue box. 

4. The Layer name data field should be empty, so type in the new name Cross Section 1 
as shown below; ensure that Fill with field is Transparency, then click OK.

5. First we will create a large pot. With that new Cross Section 1 layer active, choose the 
the Rectangle Select Tool and ensure that in the Tool Options dialogue, the Shape 
field is set to Linear as shown below.
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6. Using the guides at 200 (top) and 800 (bottom), draw a rectangle selection from layer's 
canvas left edge to right edge and hit 'enter'  on the keyboard to fix it.

7. For the purpose of this tutorial, we will use a standard Gimp gradient, Pastel Rainbow, 
to deliver the pattern effect. Remember though patterns for these pots/bowls can be 
delivered in many different ways, as can be seen from the relevant Gimp Chat thread. 
One caveat though is that any Gimp patterns you might use should preferably be 
seamless to cater for the filter's 'wrapping' effect, which impacts the left and right edges 
of the input cross section.

Select the Gradient Tool from the Tool Box and from the Tool Options choose the 
target Pastel Rainbow gradient and ensure that the Shape field is set to Linear.

8. Now left click on the selection's top left corner and hold the button; draw the cursor down 
to the selection's bottom left corner, then release the mouse button and hit 'enter' to fill 
the selection with the gradient. You should now have a canvas looking like this.
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9. Now right click on the canvas and from the menu choose Select>None to remove the 
selection from the layer.

10.Next click on Filters>Map>Map Object to display the filter parameters dialogue as 
below.

11. On the Options Tab change the settings to reflect those in the below example. We are 
removing that wireframe cover, asking for a live preview, we want the output to have a 
transparent background and to be created on a new layer. We want a sphere option not 
plane, and as you change the parameters, dynamically the Preview window and content 
will change to show a transformed shape based on the current efault parameters, which 
are held on the other tabs.

12.We will not change the Light tab in this exercise, leaving it as a Point Light from the 
default source direction. 
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13.Now click on the Material tab and change the settings to those shown below; whereby 
we are reducing the colour intensity from that light source (Intensity Diffuse) and that of 
any highlights (Reflectivity Specular) it produces.

14.The last tab (Orientation) is the one that delivers our pot size (Position Z) and 
perspective (Rotation Z), the latter by tilting the pot slightly towards you. Given that I am 
assuming a front on viewpoint, say looking directly at the pot, with my horizon line 
slightly below the pot top. So change the two Z parameters to the values shown below. 
Finally click OK to create the new modified layer.

15.Using the Position Y slider will rotate the image left or right at an angle but I'm not 
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covering that function in this tutorial.

16.  Now press OK to activate the filter and create your new layer. Your pot image should 
look like the one below. Rename this layer as Rainbow Pot. 

17.Let's now see some of the flexibility of Gimp with the output from our Map Object filter; 
we can easily change the shape of this pot, keeping the perspective intact. Duplicate the 
Rainbow Pot layer and click the 'eye' to make it invisible. Then, with the duplicated layer 
active, select the Scale Tool,.click on the canvas to show the Scale Tool dialogue and 
unlink the chain that links Height and Width together. Now click on the Width down 
arrow until it reaches 700 pixels. 

18.You will see the pot change size and shape dynamically and on completion your canvas 
should look like this.
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]

19.For our second attempt you can now repeat the above steps from 3 to 18 with the 
changes noted below, but first make the Background layer the only one visible:

1. Step 4 – make the new layer name  Cross Section 2
2. Step 6 -  use guidelines at 600 and 800 pixels to draw the rectangle selection
3. Step 8 – after it's completion and before Step 9, click on Filters>Noise>CIE Ich 

Noise to display the dialogue box and just click OK to provide a modified rectangular 
colouring that looks like this:
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4. Step 14 – modify the two Z parameters to 0.80 and 5.0 as shown below.

5. Step 16 - your new bowl image should be created and look like the one below. 
Rename this layer as Rainbow Bowl. 
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6. Step 17 – make the scaling width 600 pixels for the duplicated Rainbow Bowl and 
you should achieve a new shaped bowl like this:

20.For our third attempt you can now repeat the steps from 3 to 18 with the changes noted 
below:
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1. Step 4 – make the new layer name  Cross Section 3
2. Step 6 -  use guidelines at 500 and 600 pixels to draw the rectangle selection
3. Step 14 – use the same two Z parameters of 0.80 and 5.0 used in our second 

attempt 
4. Step 16 - your new image should be created and look like the one below. Rename 

this layer as Rainbow Dish

5. Step 17 –link the chain so that Height and Width operate together; then make them 
both scale down to 600 pixels for the duplicated Rainbow Dish layer and you should 
achieve a new smaller shaped dish like this:

Conclusion

You have created 6 different pots/bowls/dishes simply by using this filter and just a couple of 
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subtle variations of its parameters. The key driver for the shape filter outcomes in this operation 
is actually the thickness of the 'cross section' and its location on the canvas. Further 
experimentation in that area will help you achieve more attractive results.

We have just used a simple 'gradient pattern' in these examples but it is possible to be quite 
inventive with the patterns used – refer to my Gimp Chat thread for some examples -

http://gimpchat.com/viewtopic.php?f=11&t=19767 

You should explore/experiment further with different patterns to use with this filter. 

Creating a Rim for the Pot/Bowl /Dish

These filter created objects really need the finishing touch of an obvious rim around the top to 
provide an appearance of material thickness and there are several ways to approach this in 
Gimp. Whilst I would typically just create and stroke paths for this job, I thought I would 
demonstrate here some neat capability of the Ellipse Select Tool to deliver a selection, then a 
path for stroking with a brush and finishing off with some bevelling for a rounded shape.

For this exercise we will use the down scaled Rainbow Bowl from our second attempt above.

1. Make sure this down scaled Rainbow Bowl and the Background are the only visible 
layers.

2. Following the scaling, our target image is left side of screen, so choose the Move Tool, 
click and hold the button then drag the bowl to centre screen with its base one the 800 
pixel guide. Then right click on the canvas and from the pop up menu select 
Layer>Layer to Image Size. Now, we do not need those guides any more so select and 
click on Image>Guides>Remove All Guides. This is now what we are going to work on.
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3. Choose the Ellipse Select Tool and ensure that the Tool Options have Expand From 
Centre checked and Fixed unchecked as below:

4. Now place the cursor in the centre of the top of the bowl and drag out a selection that 
approximately relates to edges of the top of the bowl, like this
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5. Now in the Tool Option uncheck the Expand From Centre option. You will now find that 
that the box like handles on each corner and each side of the rectangular frame holding
the selection, will operate independently and allow you to fine tune the shape of the 
selection to the rim of the bowl. Those 'marching ants' will be walking around it, so press 
enter to fix the selection and remove the frame.

6. Now right click on the canvas and from the pop up menu choose Select>To Path then 
right click again and choose Select>None.

7. Next we will stroke the newly created path with a particular colour, using standard brush 
2. Hardness 100 set at 20 pixels.

8. The colour I have chosen to use is HTML 496e52, one that is already in that rainbow 
finish. So click on the Foreground Colour icon to open the dialogue window and 
highlight the current HTML field (should be all zeroes for black). Type in 496e52 and hit 
enter – a medium green colour will become the Current active colour, as shown below. 
Then click OK to close the dialogue.
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9. Now create a new transparent layer above the Rainbow Bowl layer. With that new layer 
active and the 2. Hardness 100 brush set at 20 pixels, right click the canvas and choose
Edit>Stroke Path from the menu. Rename the layer as 496e52 rim.

10.You should now have an image with a wide flat green rim as shown below:
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11. Create another new transparent layer above the 496e52 rim layer and rename it 
Rainbow rim.

12.Now make  the 496e52 rim layer the active layer and use the Fuzzy Select Tool to click 
on the green rim to obtain a selection of it.

13.Next make the Rainbow rim layer active and select the Gradient Tool, which should still
have the Pastel Rainbow gradient active. Place the cursor on the left edge of the rim 
selection and drag the gradient across to the right edge. Your canvas should now 
resemble the one below:
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14.Change the Layer Mode of the Rainbow rim layer from Normal to Overlay, which 
lessens the colouration and intensifies the green hue.

15.Lets now put the finishing touch to our bowl. Select Filters>Decor>Chisel or Carve to 
show the dialogue window. Change the parameters to reflect those shown below, to give 
us  us a rounded chiselled effect in a new layer.

16.  In that new layer, change the Layer Mode from Hard Light to Overlay and set the 
Opacity at 80%. Your finished bowl now has a new rounded rim of colour matching the 
bowl itself.
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Postscript

Well that is it. Thank you for attempting this tutorial. I hope that you enjoyed the journey, learned
something new and are keen to practice more. GIMP has so much to offer and no matter how 
long you have been using it there will always be new things to learn.

If you have any questions or issues with this tutorial or if you locate any errors, please detail 
them in the Gimp Chat thread http://gimpchat.com/viewtopic.php?f=11&t=19767 .

I will leave you with something else I created in GIMP, a peaceful, misty sunset over the Blue 
Mountains at Mudgee.
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