It is currently Mon Oct 23, 2017 12:55 am


Latest GIMP Scripts & Plug-ins

All times are UTC - 5 hours [ DST ]



Post new topic Reply to topic  [ 64 posts ]  Go to page 1, 2, 3, 4, 5 ... 7  Next
Author Message
 Post subject: Script-Fu Scrolling Interface V1.1 For GIMP 2.8.14
PostPosted: Wed Aug 27, 2014 12:22 am  (#1) 
Offline
GimpChat Founder
User avatar

Joined: May 22, 2008
Posts: 5207
Location: Gimpville
Due to the addition of several updates to the Script-Fu Interface in GIMP 2.8.14, the Scrolling Interface Modification required updating, as well.

Note: This update is for GIMP Version 2.8.14 only. Use Version 1.0 for previously released GIMP 2.8.x versions. If you have upgraded to GIMP V2.8.14, you will need to install this version of the Script-Fu Scrolling Interface.

If you have upgraded from GIMP V2.8.x to GIMP V2.8.14, please replace the old script-fu binary in your plug-ins folder with this one.

Thanks!

Script-Fu Scrolling Modification V1.1 For Windows_x64 | Windows_x32 - Kudos To Pogogogo for compiling.

Attached below is the source code, along with 64bit & 32bit Linux binaries, which were compiled under Fedora 20. These binaries should also work with most other Linux distributions running GIMP 2.8.14. Also, attached is Partha's 64bit binary for MAC OSX.


Attachments:
File comment: Script-Fu Scrolling Interface V1.1 MAC x64
Script-Fu-Scrollng-InterfaceV1.1-For-GIMP-2.8.14-MAC_x64.zip [66.28 KiB]
Downloaded 321 times
File comment: Script-Fu Scrolling Interface V1.1 Linux x64
SF-Scrolling-InterfaceV1.1-For-GIMP-2.8.14-Linux_x64.zip [223.35 KiB]
Downloaded 414 times
File comment: Script-Fu Scrolling Interface V1.1 Linux x32
SF-Scrolling-InterfaceV1.1-For-GIMP-2.8.14-Linux_x32.zip [215.16 KiB]
Downloaded 304 times
File comment: Script-Fu Scrolling Interface V1.1 Source Code
SF-Scrolling-InterfaceV1.1-For-GIMP-2.8.14-Source.zip [6.45 KiB]
Downloaded 431 times

_________________
“If you reach for the stars, you just might land on a decently sized hill.” - Stuart Hill
Share on Facebook Share on Twitter Share on Orkut Share on Digg Share on MySpace Share on Delicious Share on Technorati
Top
 Post subject: Re: Script-Fu Scrolling Interface V1.1 For GIMP 2.8.14
PostPosted: Wed Aug 27, 2014 1:25 am  (#2) 
Offline
Global Moderator
User avatar

Joined: Aug 10, 2012
Posts: 9281
Location: Formerly From NYC, Now in Arizona
Just when I got my 2.8.10 all sorted out too. Can't stand in the way of progress though.
Thanks Tux. :bigthup

_________________
Image
"A wise man learns more from a foolish question than a fool can learn from a wise answer"
Image
My YouTube Channel


Top
 Post subject: Re: Script-Fu Scrolling Interface V1.1 For GIMP 2.8.14
PostPosted: Wed Aug 27, 2014 11:54 am  (#3) 
Offline
GimpChat Founder
User avatar

Joined: May 22, 2008
Posts: 5207
Location: Gimpville
Well, the code to allow for a scrolling interface didn't change but there were several updates to the Script-Fu plug-in itself in the V2.8.14 release. For those who are using GIMP 2.8.14, I highly recommend using V1.1 of the scrolling interface.

Hopefully, someone will provide Windows 64bit & 32bit binaries for this modification. :cool

_________________
“If you reach for the stars, you just might land on a decently sized hill.” - Stuart Hill


Top
 Post subject: Re: Script-Fu Scrolling Interface V1.1 For GIMP 2.8.14
PostPosted: Wed Aug 27, 2014 1:44 pm  (#4) 
Offline
GimpChat Member
User avatar

Joined: Apr 22, 2010
Posts: 123
SF-Scrolling-InterfaceV1.1-For-GIMP-2.8.14-Windows_x64,Done.:)
Tested Gimp 2.8.14 Win7 64-bit


Attachments:
SF-Scrolling-InterfaceV1.1-For-GIMP-2.8.14-Win_x64.zip [76.32 KiB]
Downloaded 1145 times

_________________
Image
Top
 Post subject: tmp
PostPosted: Wed Aug 27, 2014 1:51 pm  (#5) 
Offline
Global Moderator
User avatar

Joined: Nov 16, 2011
Posts: 5130
Location: Metro Vancouver, BC
Just my experience, as I didn't know about the script-fu update in Gimp 2.8.12/14.

On first launch of 2.8.12 I noticed the script-fu error in the console. The error was 'Skipping duplicate plug-in'. Renamed to script-fu.old, the next launch error was "Removing duplicate PDB procedure'. Removed (.gimp-2.8/plug-ins) script-fu, no errors, everything seems to work as it should. Very nice addition!

No issues so far (Ubuntu 14.04, 32bit).

_________________
Image
Gimp 2.8.18, Linux, median user
Gimp Chat Tutorials Index
Spirit Bear (Kermode)


Top
 Post subject: Re: Script-Fu Scrolling Interface V1.1 For GIMP 2.8.14
PostPosted: Wed Aug 27, 2014 1:54 pm  (#6) 
Offline
GimpChat Founder
User avatar

Joined: May 22, 2008
Posts: 5207
Location: Gimpville
Thank you so much, pogogogo!

_________________
“If you reach for the stars, you just might land on a decently sized hill.” - Stuart Hill


Top
 Post subject: Re: GIMP 2.8.12 Released (BROKEN) - GIMP 2.8.14 Released
PostPosted: Wed Aug 27, 2014 2:06 pm  (#7) 
Offline
GimpChat Founder
User avatar

Joined: May 22, 2008
Posts: 5207
Location: Gimpville
Odinbc wrote:
On first launch of 2.8.12 I noticed the script-fu error in the console. The error was 'Skipping duplicate plug-in'. Renamed to script-fu.old, the next launch error was "Removing duplicate PDB procedure'. Removed (.gimp-2.8/plug-ins) script-fu, no errors, everything seems to work as it should. Very nice addition!

The warning "Skipping duplicate plug-in" is perfectly normal when you add the scrolling interface to your plug-ins folder. GIMP will use the first plug-in it encounters, which in this case is the script-fu binary containing the the scrolling modification you placed in the user plug-ins folder.

If for some reason you don't want to see this warning, you would need to replace the existing script-fu binary in the global plug-ins folder with the scrolling script-fu binary. This will replace the original script-fu binary so I think it's better to just place the scrolling script-fu interface in the user plug-ins folder and simply ignore the duplicate message, which is only a harmless warning that you have two of the same plug-in installed.

_________________
“If you reach for the stars, you just might land on a decently sized hill.” - Stuart Hill


Top
 Post subject: Re: Script-Fu Scrolling Interface V1.1 For GIMP 2.8.14
PostPosted: Wed Aug 27, 2014 2:10 pm  (#8) 
Offline
Global Moderator
User avatar

Joined: Nov 16, 2011
Posts: 5130
Location: Metro Vancouver, BC
What are the best scripts to test?
G'MIC has the scrollbar without this script-fu in 2.8.14.

_________________
Image
Gimp 2.8.18, Linux, median user
Gimp Chat Tutorials Index
Spirit Bear (Kermode)


Top
 Post subject: Re: GIMP 2.8.12 Released (BROKEN) - GIMP 2.8.14 Released
PostPosted: Wed Aug 27, 2014 2:26 pm  (#9) 
Offline
Global Moderator
User avatar

Joined: Nov 16, 2011
Posts: 5130
Location: Metro Vancouver, BC
GnuTux wrote:
The warning "Skipping duplicate plug-in" is perfectly normal when you add the scrolling interface to your plug-ins folder. GIMP will use the first plug-in it encounters, which in this case is the script-fu binary containing the the scrolling modification you placed in the user plug-ins folder
Isn't Gimp skipping script-fu in .gimp-2.8/plug-ins?
console message wrote:
Skipping duplicate plug-in: '/home/odinbc/.gimp-2.8/plug-ins/script-fu'
This is the same message with either script-fu v1 and v1.1.

_________________
Image
Gimp 2.8.18, Linux, median user
Gimp Chat Tutorials Index
Spirit Bear (Kermode)


Top
 Post subject: Re: GIMP 2.8.12 Released (BROKEN) - GIMP 2.8.14 Released
PostPosted: Wed Aug 27, 2014 3:52 pm  (#10) 
Offline
GimpChat Founder
User avatar

Joined: May 22, 2008
Posts: 5207
Location: Gimpville
Odinbc wrote:
GnuTux wrote:
The warning "Skipping duplicate plug-in" is perfectly normal when you add the scrolling interface to your plug-ins folder. GIMP will use the first plug-in it encounters, which in this case is the script-fu binary containing the the scrolling modification you placed in the user plug-ins folder
Isn't Gimp skipping script-fu in .gimp-2.8/plug-ins?

I remember testing this at one point and I believe it looked for plug-ins based on the order you have specified in Edit/Preferences/Folders/Plug-ins.

Image
Mine displays this message: Skipping duplicate plug-in: '/usr/lib64/gimp/2.0/plug-ins/script-fu'

In most cases, the default would be .gimp-2.8/plug-ins but since the order can be changed, I thought to best to be more precise.

Odinbc wrote:
console message wrote:
Skipping duplicate plug-in: '/home/odinbc/.gimp-2.8/plug-ins/script-fu'
This is the same message with either script-fu v1 and v1.1.

Well, it looks like you might have your global folder listed before your user folder. If that is the case, you'll need to reverse the order, or remove the script-fu binary from the global folder, or replace the script-fu binary in your global folder with the scrolling mod.

_________________
“If you reach for the stars, you just might land on a decently sized hill.” - Stuart Hill


Top
Post new topic Reply to topic  [ 64 posts ]  Go to page 1, 2, 3, 4, 5 ... 7  Next

All times are UTC - 5 hours [ DST ]


   Similar Topics   Replies 
No new posts Attachment(s) Script-Fu Interface Scrolling Modification V1.0 Official Release

234

No new posts Attachment(s) Scrolling Animation Logo Script for GIMP

6

No new posts Attachment(s) Script request for scrolling text banner

4

No new posts Scrolling and Wraps layer animation Script for GIMP

0



* Login  



Powered by phpBB3 © phpBB Group