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Creating Gradient Blends For Use In Gimp Art

Introduction

| have created this 'helper' document following a request from a member of the Gimp Chat
forum, Sallyanne, in the thread 'Blend — Gradient Tool' - http://gimpchat.com/viewtopic.php?
f=11&t=20207 .

In that thread, initiated by Gimper66, he asked whether Gimp was capable of producing similar
results to the Photoshop image he had posted. | demonstrated that Gimp was certainly
capable of producing similar results (see front cover) and because of that, member Sallyanne
requested a tutorial on the methods | used.

Objective

So, this document seeks to help both new and more experienced GIMP users create images
something like those shown on the title page and the Gimp Chat thread. However, rather than a
pure tutorial to create, step by step, the front cover image as shown, | will focus on exploring
and exemplifying the toolkit that | used to do the job.

The three tools used are:

1. RMA Path Blend script by Rob Antonishen — an old but powerful script which renders the
space between two paths with a gradient

2. Generate Intermediate Paths (Path-inbetweener) plug-in by Ofnuts— a plug-in which
creates multiple paths between two specified paths

3. Stroke or Fill Visible Paths plug-in by Ofnuts — a plug-in that strokes all visible paths
using either the foreground colour or the current gradient.

| will also address the necessary use of paths to create the required structural shapes in the
target outcome, as, combined with these tools, they deliver an enormous degree of flexibility in
creating that target image.

In essence tools 2 and 3 are used in combination, as will be shown below, so this helper will
comprise two descriptive sections:

1. Using Path Blend
2. Using Generate Intermediate Paths and Stroke Visible paths

Assumptions

For this document | assume, that readers:
* can navigate Gimp
* can create simple paths

* understand layer and path dialogues
* understand plug-in dialogue boxes
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Conventions used in this tutorial

Instructions on accessing and using various GIMP functions and filters are expressed in the
following format:

Image>Guides>New Guide (by Percent)...

This means that the user with a mouse, firstly left clicks on Image from the main GIMP menu,
which then shows a drop down list of Image options available.

From this list the user with a mouse then left clicks on Guides to show the Guides options

available. From this list the user then left clicks on New Guide (by Percent)... to display the
form for completion:
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Section 1 - Using Path Blend

In this section we will look at Path Blend capability with differing path types/shapes and then
recreate the main gradient blends in the centre of the cover page image.

Path Blend is extremely flexible and will function against two defined paths:
» of any shape and size
* with any numbers of anchor points

Example 1 — two paths of similar shape, roughly parallel but with one rotated slightly, against
which we process Path Blend using the FG to BG (RGB) standard gradient — in this case with
FG = 072be1 blue and BG = €90407 red.

example 1 path |

@l cxample 2 path

Path Blend can be opened via Filters>Render>Path Blend, where the dialogue box allows
you to select the from and to paths and also the gradient you wish to use as shown below.

4@ Script-Fu: Path Blend it
Blend from: [ path_blen tut ... xample 1-406 v l
Blend to: path_blen_tut_... xample 2-405 Vl

B Use Sampled Gradient

k

Segment Overlap: 1.0

1

v [ rest |[ ok [ cames

Note that the gradient blend commences at the selected ‘Blend from' path, hence in this case
we created a vertical blue to red progression as shown in the completed image hereunder..
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Example 2 — two paths of similar shape, but with one rotated so that it actually crosses the
other, against which we again process Path Blend using the FG to BG (RGB) standard
gradient with FG = 072be1 blue and BG = 90407 red.

L}
example 3 path @

il cxample 4 path

& Script-Fu: Path Blend ®
Blend from: | path_blen tut ... xample 3-403 V‘
Blend to: | path_blen tut ... xample 4-404 ‘

B Use sampled Gradient

Segment Overlap: 1.0 5

vop ][ reset )[ ox ][ comce
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With the path crossover we can see that Blend from example 3 path moves above example 4
path and the gradient blend goes with it, reversing the direction of the blend as shown below.

Already from these two examples we can see the power of this gradient tool in shaping our
artwork similar to that on the front cover. Simple, dual colour gradients work very well, but there
is a place for more exotic (home grown!) gradients too.

Example 3 — now let's move on to more complex path creation so that we can produce the
central blended area of the front cover image. In this case | created four separate paths in two
sets and ran Path Blend against each set in turn.

The intention of this first set was to create a gradient blend between the two paths, but as you
see below, when the second path was drawn, | followed the lines of the first path in the centre of
the canvas, in order to have the gradient blend on both sides but a void in the middle; refer
annotation below.
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example 5 path

Planned
Void

example 5 path

Once again we process Path Blend using the FG to BG (RGB) standard gradient with FG =
072be1 blue and BG = e90407 red from example 6 path to example 5 path, top to bottom.

Now | want to fill that void so that it forms a concave aspect, as though we are looking into a
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cave. This is where the second set of paths come in as shown below.

example 7 path

B cxample 8 path

Again we process Path Blend using the FG to BG (RGB) standard gradient with FG = 072be1

blue and BG = e90407 red from example 8 path to example 7 path, bottom to top to fill the
void.

Now the blue is at the base of the void shape, red at the top and a subtle dose of black shading
helps complete the cavernous effect. Additional red or blue highlights along the paths can also
be used and blurred for effect.

Okay, that is the foreground completed; section 2 deals with creating the main background
component..
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Section 2 - Using Generate Intermediate Paths & Stroke Visible paths

When | first saw Gimper66's Photoshop image, it was clear that whilst the foreground curves
were fully opaque, the background curves were made up of individual coloured lines, with
transparency between them. | could not utilise Path Blend to replicate that type of curve, but
there is another tool well suited for this job and that is Ofnuts' plug-in Generate Intermediate
Paths (Path Inbetweener).

This plug-in will generate any number of separate paths between two target paths of any shape
or size, can produce four different output line styles filling the gap (exemplified below) and can
use a third path as a 'shaper' for the auto created paths. One simple rule though does apply
here, both the to and from paths must contain the same number of anchor points.

Typically the paths produced by this plug-in will be used for 'stroking' using Ofnuts' Stroke
Visible Paths plug-in, with your selected brush (including the brush dynamics), choosing either
the foreground colour or the current gradient. In effect, we could have used these two Ofnuts
plug-ins to create the gradient blend images in Section 1.

So in this section we will look at this extremely flexible Generate Intermediate Paths plug-in,
its ability to produce different line styles between the paths, and look at what options | used to
create those lined background shapes in my response to the Photoshop image.

Example 4 — using the two paths of similar shape from Example 1 above, lets check the style of
paths coverage available.

example 1 path J

@l example 2 path

Right click on the example 1 path in the Paths Dialogue to show the available menu options,
then select and click Tools>Generate intermediate paths to bring up this plug-in's dialogue
box.

The active example 1 path is our assumed start path and we can then choose our end path,
example 2, from the End path drop down. For these example | choose 45 Total steps from
start to end, and lastly selected the default Stretch of Linear which provides a proportional
solution between the paths.
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4@ pythen-fu-path-inbetweener >

Generate intermediate paths...
5 C:\Users|Tony\AppData\Roaming\GIMP\2.10\plug-ins\path-
M inbetweener-0.2.py

End path l path_blen tut examples.xcf-3 [ example 2-161 V]

-

Total steps 45 =
Stretch l Linear V]
Use guide [ Mo ]

Guide path l path_blen_tut examples.xcf-3 [ example 1-160 V]

0K H Cancel ]

The result of this action is shown below.

Here are the results for the same start and end paths, still 45 interim steps, but using a Stretch
of Acceleration (left below) and Deceleration (right below). Note for the former, the interim
step paths progress with continually decreasing intervals. For the latter it is the opposite effect.

Lastly, for the Swing option, we obtain a combination of the above two impacts as shown below
with path steps progressively increasing in size towards the centre, then progressively
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decreasing until the end.

Like Path Blend, this plug-in allows paths to be of any shape and to cross over.

Each of these options has a place in Gimp art works, where they can be stroked for effect. Lets
look now at the solution | created for the background curves in the front cover image.

Example 5 — Firstly | drew two paths to represent the background shaped curve as shown
below.

™~ Bl example 10 path

example 9 path

Then with example 9 path active | called up the Generate Intermediate Paths plug-in by right
clicking on the active path, selecting Tools> Generate Intermediate Paths and made the
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following selections in the dialogue form.

4@l python-fu-path-inbetweener X

™ Generate intermediate paths...
¢ Cr\Users|Tony\AppData\Roaming|GIMP\2.10\plug-ins\path-
M inbetweener-0.2,py

: ) End path path_blen_tut examples.xcf-3 j example 10-215 Vl
I: > Total steps 60 :
I: > Stretch [ Linear ~ l
Use guide [ Mo l
Guide path | path_blen tut examples.xcf-3 j example 9-216 l

o e

The nomination of 60 path steps was somewhat arbitrary, based on experience | suppose, but |
had selected the 2. Hardness 100 Gimp brush at Size 3 pixels for stroking purposes and felt
that would deliver my target result. The resulting paths looked like this.

Then with example 9 path active | called up the next plug-in via Image>Stroke or fill visible
paths to show the dialogue box hereunder.

Obviously, | selected From gradient rather than Foreground color, Stroke rather than Fill,
Single layer output rather than Multiple and lastly Background fill of Transparent.
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& python-fu-stroke-fill-visible-paths *

r Stroke or fill visible paths...
¢ Cr\Users|Tony\AppData\Roaming|GIMP\2.10\plug-ins|stroke-
W visible-paths-0.6,py

Color l From gradient Vl
|:: ) Stroke/Fill l Stroke v l
|:: ) Layers l single Vl
. 100

Opacity
) Background fill |§Trar|sparent V|

Layer Name

v ==

The result of the stroking with gradient is shown here.

With this new layer moved to the bottom of the stack (above background layer), some slight
darkening of the arch for effect and other key layers made visible again, this was the result.
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After this, to complete the job, | did add some further elements that were in the original
Photoshop image, including another set of stroked paths.

But for all intents and purposes the above narrative should meet Sallyanne's request (I hope).

2" December 2022 Created by 'Oldmangrumpy' for Gimp Chat Page 14



